Temperature sensor unit for !986 Piazza.

General Bellett, Gemini 75-98, Piazza 81-93, Bellel, Florian, 117 Coupe, Minx, Aska technical discussion.
Post Reply
sbs
Site Supporter
Site Supporter
Posts: 92
Joined: Sun Oct 19, 2008 3:09 pm
Location: Wheatbelt, W.A.

Temperature sensor unit for !986 Piazza.

Post by sbs » Sat Jun 18, 2011 10:07 am

Hi folks,
Here is a nice little scenario for you. I am out driving to a neighbouring town the other day when I notice the temperature guage in the red warning zone. I pulled over to the side of the road, expecting to see steam and hear the sound of boiling water, and absolutely nothing. I could place my hand on the radiator, the engine, anywhere in the engine bay and it was not remotely hot.
I thought that it might have been something to do with the thermostat so I put in a new spare one, but to no avail. I am needing a bit of advice here if someone can help. Could it be a faulty sender unit? Is it possible the dash guage has given up the ghost?
The bottom line is, of course, that I don't want to be driving around not knowing if the engine has overheated. Any suggestions will be much appreciated. Thanks folks, regards, sbs.

User avatar
wedgenut
Site Admin
Site Admin
Posts: 1636
Joined: Mon Jul 04, 2005 9:39 pm
Location: Hibiscus Coast NZ

Post by wedgenut » Mon Jun 20, 2011 5:05 pm

Probably the sensor on the top of the manifold next to the thermostat housing. You can test it using the data in the manual and a multimeter. The normal way to test it is, ignition on and engine off remove the wire and the gauge should read cold, short the wire to earth and it should climb up to the other end. Take it off and it will drop back to cold. That tests the wiring and the gauge. If that is all okay and the engine isn't overheating the sensor is effed. However if you have a digidash then good luck, I know nowt about them.
Try the test above first. It is easy and only takes a few minutes
So many cars, so little cash

sbs
Site Supporter
Site Supporter
Posts: 92
Joined: Sun Oct 19, 2008 3:09 pm
Location: Wheatbelt, W.A.

Test of sender unit.

Post by sbs » Wed Jun 22, 2011 2:53 am

Hi there Wedgie,
I appreciate the advice and I will run the test in the next day or two. Since posting the request for help I have had similar advice from another source and I will get back to you with the outcome.
Thanks again, regards, sbs.

User avatar
archangel62
Senior Member
Senior Member
Posts: 233
Joined: Sun Aug 14, 2005 7:07 pm
Location: Adelaide, South Australia

Post by archangel62 » Thu Jun 23, 2011 5:30 pm

I reckon the sender for the digi dash will be the same. It'll have some kind of capacitor or "slower" unit to dull its response so it's not spastic jumping all over the place... but I'd imagine it will "effectively" do the same thing during a test, provided everything's good. Another good test is to remove the whole sender and immerse in water, normal running temp should be rouuuughly 75-85 deg celsius. You could also try connecting another 4Z series sender to the wire and doing the same, or even try a "filthy Gemini" sender ;)
Indigo - '76 TX Gemini sedan, G180W+T project,
Abigail - '81 TE sedan, white, G180W ITB project,
New Hotness - TG Gemini drift car, orange, 4ZE1+T
Tardis - 1986 Piazza 4ZC1-T, black, forged, 136rwkw @13psi
Coupe - TX coupe grip car, "do it later", G180W+twin carbs
Trevor aka Jimmy's Gem - Grandpa-spec TD
BA Falcon - Tow car

User avatar
wedgenut
Site Admin
Site Admin
Posts: 1636
Joined: Mon Jul 04, 2005 9:39 pm
Location: Hibiscus Coast NZ

Post by wedgenut » Thu Jun 23, 2011 6:08 pm

it is not uncommon on most vehicles, regardless of instrument style to have a resistor in the circuit to smooth out signal fluctuations but it will not alter the result unless it is faulty of course
So many cars, so little cash

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Sat Jun 25, 2011 10:07 am

You mean capacitor? A resistor will change the current (range) but not do any smoothing.

Caps are also use to remove noise when used for digital inputs, though they are small (typically 0.01 or 0.1uF) and part of the digital input on the CPU board etc. (Otherwise the software has to get a true-RMS reading - a cap is much cheaper!)
IZU069 - ISUZU means a lot to me.

User avatar
wedgenut
Site Admin
Site Admin
Posts: 1636
Joined: Mon Jul 04, 2005 9:39 pm
Location: Hibiscus Coast NZ

Post by wedgenut » Sat Jun 25, 2011 2:42 pm

Resistor/capacitor shimacitor, who cares, one box of electronic shit is pretty much like another and of little interest to me other than I know they have them to stop the guage needles dancing all over the shop every time you go over a bump or round a corner.
So many cars, so little cash

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Sat Jun 25, 2011 4:57 pm

Those that keep inserting resistors care... it's logical that the higher resistance, the slower electricity flows (that's why sub speakers are 1 Ohm etc - to make up for how much slower heavy base travels compared to 4 & 8 Ohm tweeters), hence adding resistors filter out the bounces.

I've had too many quoting web sources where such (MINOR!) errors are made. Those errors often foster religions! (Just look at Hubbard's tax return LOL.)
Yes, it is by those that miss the point, but they are the ones that seem to bark and bite the most. And although many make good money from the spin-off effects, the victims IMO suffer.


I'm about to sell cable that has conductance instead of resistance. Hence audio systems are much crisper and faster, and ignition power increases because it doesn't have time to dissipate energy as does in high-resistance ignition leads (did you know they are several k-Ohms!!?) - just to name a few benefits.
I might even sell some to those $%$#@! local 4WD & camping forums so they don't have to worry about dc-dc converters to charge their (auxiliary) batteries. (After all, the near 100% efficiency should make up for the condle cost. Plus I can color-match to their harnesses.)
Those that get my point should be able to save heaps of money...
Same too for those that want to learn or understand.
IZU069 - ISUZU means a lot to me.

sbs
Site Supporter
Site Supporter
Posts: 92
Joined: Sun Oct 19, 2008 3:09 pm
Location: Wheatbelt, W.A.

Piazza sender unit - temp.

Post by sbs » Tue Jun 28, 2011 8:10 pm

Hi folks,
Well, it turns out that Wedgie was spot on (is he ever anything else... ) and the sender unit was stuffed. A replacement unit was available off of the shelf at the local auto electrical store and things are back to normal.
Thanks as always folks for the advice, By the way, the spare Piazza is still avilable for anyone looking for a good Piazza. Cheers, sbs.

Post Reply