Question about timing...

General Bellett, Gemini 75-98, Piazza 81-93, Bellel, Florian, 117 Coupe, Minx, Aska technical discussion.
User avatar
Ghost
Member
Member
Posts: 137
Joined: Fri May 04, 2007 2:12 pm
Location: Auckland, NZ
Contact:

Post by Ghost » Tue Jul 10, 2012 11:23 am

Have you got rid of the old fuel yet??
It wasn't running one of those useless "bio" fuels was it, they do separate when stored for long periods of time.
1986 Piazza - 1984 Piazza
1986 Heron MJ1
www.mvpc.co.nz www.ihwedding.co.nz

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Tue Jul 10, 2012 12:46 pm

Well, I have not dumped the old gas yet. I might do that here soon though, as I am getting really tired of this problem and I am running out of things to try, short of replacing parts and spending money.

Bart
Image

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Wed Aug 01, 2012 9:37 am

OK, I have good news and bad news.

My friend Mike, who has damn near 35 years of hard core auto mechanics behind him, came out from Chicago to run the Rubicon Trail last week. We had some time to chill at the house and we worked on the Impulse.

The good:
My timing WAS in fact off by one tooth with the distributor. With him there, and another friend, one guy turning the dizzy, Mike with the timing light, and me cranking the motor, we were able to get that squared away. So now the car will run, but not without throttle. We checked the TPS and a bunch of other stuff, very methodically, and all Mike can put together is that it must be too much fuel. Which brings me to...

The bad:
My fuel pressure is not where it is supposed to be. Its way too high, and after Mike looked at my plugs, he told me that it is running way very rich, and flooding out my cylinders, and that must be why I am still not able to keep it running at idle. Plus, while it is running, it pops and spits so Mike thinks I probably need to adjust the valves.

He had to hit the road, but left me with this:

1) Replace the OEM fuel pressure regulator
2) See if I can replace the missing fuel damper
3) Adjust the valves

After that, he thinks it should start behaving better.

What do you all think?

Bart
Image

User avatar
Ghost
Member
Member
Posts: 137
Joined: Fri May 04, 2007 2:12 pm
Location: Auckland, NZ
Contact:

Post by Ghost » Wed Aug 01, 2012 9:51 am

Well at least your fuel pump is good!
I would say he was on the money with that diagnostics, I would probably start with the fuel damper since it's missing in the first place, though I'm no expert on fuel systems, engines or cars...
1986 Piazza - 1984 Piazza
1986 Heron MJ1
www.mvpc.co.nz www.ihwedding.co.nz

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Wed Aug 01, 2012 9:58 am

Ghost wrote:Well at least your fuel pump is good!
I would say he was on the money with that diagnostics, I would probably start with the fuel damper since it's missing in the first place, though I'm no expert on fuel systems, engines or cars...
Yeah, I cannot find a reference to it at ANY parts shop here. Do you guys know if you can get one over there?

Bart
Image

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Wed Aug 01, 2012 5:53 pm

I found nothing in the GMH parts book nor the PiazzaManual.pdf.

There are the 2 fuel pumps, and the pressure regulator which is spec'd at 36.3psi or 2.55 kg/cm2 (2.5 Bar).
The rest are vapor separators etc.

I thought RodeoBob said something about the (beauty of the) Piazza fuel system being damped, but that may have been by design rather than a specific damper.


What makes him think "the damper" is missing? (They aren't fitted to all EFIs.)


Maybe just replace the regulator and then see how it performs.
I doubt that a damper is required.
IZU069 - ISUZU means a lot to me.

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Thu Aug 02, 2012 1:38 am

The damper IS missing. Here's the story.

The previous owner told me that at some point in the cars life, there was a fuel leak at "the fuel pressure regulator". So his mech replaced the "fuel pressure regulator" with this Bosch one for a BMW.

After I took possession of the car, I discovered that what was actually removed was one of two fuel dampers, not the actual FPR. The FPR is still in the car, and still original as far as I know. Here is a picture of an engine bay from the same year, same model Impulse as mine, the arrow points to the damper.

Image

The car actually has two dampers, one on the input side and one on the output side of the fuel rail. If you look at the pic above, you can see the other one behind the arrow. You can also see the pressure regulator underneath the damper where the arrow points.

Your Piazza's from Oz do not have these dampers? I believe this is the correct info:

8944083700 198503 - 198705 + 4ZC1 ENG(LR9) DAMPER; FUEL

Now, I don't think this part is needed either, not to get the car running right, but I can't imagine it would hurt to have some of the missing factory parts replaced.

One thing that might be going on now, which is causing the fuel pressure to be high, is that I replaced tons of stuff under the hood, including my injectors. So now, I have new injectors that are squirting really well, and maybe the fuel pressure is just too high now with the new injectors, where before, the old injectors were a bit clogged and the fuel pressure was high, but working ok considering this. My plugs are black and the car spits and pops at me while running. I have a pressure gauge hooked up and the pressure is constant around 49-51 psi, which is too high.

So I think my buddy Mike is correct that I am getting too much fuel and I have to get it under control. I with there was another aftermarket pressure regulator that I could buy knowing it would work.

Bart
Image

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Thu Aug 02, 2012 8:25 pm

Replace the regulator and that should fix the over-pressure problem UNLESS the return fuel line is blocked (ie, check that first).


W do have the same plumbing on our Piazzas. but that arrowed part is listed as an Air Regulator p/n 8942171231.
Below that to its right is the fuel pressure regulator p/n 8941467750.
[FYI - the last digit in p/n's is the revision number. The first digit (8) signifies "Gemini" (I-Mark) etc.]

That "damper's" upper hose goes to the inlet manifold doesn't it? (Like ours, it's too big for fuel.)
I'm not certain of its exact function, but it is tied to the fuel system (maybe rising rate fuel pressure regulator? - where's Wedgy?).

But I still reckon check the replace the fuel return line for blockage and if that was ok, then replace the fuel pressure regulator.
IZU069 - ISUZU means a lot to me.

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Fri Aug 03, 2012 1:46 am

My plan of attack is as follows:

Drain all fuel out of the tank
Disconnect hard lines and blow out as much old gas as I can
Replace regulator and damper
Replace any existing rubber fuel line that I might have missed from under the car
Replace the fuel filter (again, just in case there is some crap in there now)
Do a valve adjustment
Put it back together and see what I get

Hopefully I will get to this on Sunday.

Bart
Image

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Fri Aug 03, 2012 7:23 pm

That sounds good.


IMO it is well worth renewing all rubbers after an engine rebuild or decade. (The olds are kept as spares...)

That includes the old "new"fuel filter - renew after catching any repair offwash or blobs.
IZU069 - ISUZU means a lot to me.

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Tue Aug 07, 2012 2:10 pm

So, tonight I finished with the fuel system. Dropped the tank, cleaned it, replaced all remaining rubber hoses I did not replace before. Blew out the lines with my air compressor. Installed a new FPR and a new damper. Installed another new fuel filter just in case.

Put 5 gallons of fresh mid grade in. Fuel pressure is still over 40psi and I am getting the same business. Car starts, immediately dies. If I start it and give a little throttle, it will run but it runs rough and wants to die.

Could a valve adjustment be what I need? I plan on checking the valve clearance next, but if that doesn't fix it, then I have absolutely no idea what could be left to do. I am completely stumped.

Bart
Image

User avatar
Ghost
Member
Member
Posts: 137
Joined: Fri May 04, 2007 2:12 pm
Location: Auckland, NZ
Contact:

Post by Ghost » Tue Aug 07, 2012 5:24 pm

A new fpr?
What psi is it rated for?
1986 Piazza - 1984 Piazza
1986 Heron MJ1
www.mvpc.co.nz www.ihwedding.co.nz

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Wed Aug 08, 2012 1:18 am

Ghost wrote:A new fpr?
What psi is it rated for?
Its new OEM from Isuzu. So it should be correct for this car. Not sure what it is rated for or how to find out.

Looking at the manual, I wonder if I have a faulty vacuum switching valve.

I need to check the valves also.

Bart
Image

User avatar
impulsive
Member
Member
Posts: 100
Joined: Wed Dec 15, 2010 11:36 am
Contact:

Post by impulsive » Sun Aug 19, 2012 9:10 am

Just a quick update. I'm still stumped. Timing is good. Valve lash is good. Completely cleaned the fuel system. OEM FPR and damper installed. Changed the IAC again. Cleared the ECU. Same business. Starts, then dies right away.

I guess next I will change the coolant temperature sensor. After that, there really isn't anything I haven't touched.

This is a weird one.

Bart
Image

IZU069
Power Moderator
Power Moderator
Posts: 963
Joined: Wed Sep 14, 2005 2:59 pm
Location: Melbourne (Orstralia)

Post by IZU069 » Sun Aug 19, 2012 10:34 am

Maybe power the fuel pump(s) direct in case they are not being kept on.
I assume you have the ITEC ECU (optical distributor; locked) and not the Bosch-copy JECs system (mechanical dizzy with vac advance) - not that I recall how the JECs controls the fuel pump, but Bosch were too stupid not to have the ECU control the pumps.

But you should NOT be getting an over-high fuel pressure. Either the pressure regulator is wrong, or there is a return blockage. (Or your fuel tank shares the same pressure!)
But others are more knowledgeable on that issue.


Sorry if I have repeated something from before - I have lost track, though I know you replaced the FPV,
IZU069 - ISUZU means a lot to me.

Post Reply