dash

Post Reply
tunney
Member
Member
Posts: 51
Joined: Fri Nov 11, 2005 5:34 pm
Location: down the shed in south oz

dash

Post by tunney » Mon Apr 16, 2007 7:51 pm

now i know this question has probably been answered.

but i'll be driving along and all of a sudden my cluster goes off now i have check the fues and it's all good just seems like a bad earth where would i start to look ??? thanks

User avatar
Bradlze
Member
Member
Posts: 140
Joined: Mon Aug 29, 2005 6:10 pm

Post by Bradlze » Tue Apr 17, 2007 5:48 pm

piazza manual is your friend wiring in the piazza are crazy

User avatar
Bugle
A total post whore
Posts: 1007
Joined: Sun Jul 17, 2005 11:41 pm
Location: Sydney

Post by Bugle » Tue Apr 17, 2007 10:54 pm

The problem is usually cracked solder joints on the circuit board inside the dash

User avatar
Chris
APC Member
APC Member
Posts: 1079
Joined: Thu Jun 30, 2005 9:37 pm
Location: Melbourne

Post by Chris » Thu Apr 19, 2007 1:36 pm

I remember you have done years ago a post about this and how to fix with pics..

This may help:

http://www.ozisu.com/forum/viewtopic.ph ... light=dash

http://www.ozisu.com/forum/viewtopic.php?p=3602#3602

(pics are gone)

and their many more posts about this problem
LESS SHOW, MORE GO!!

2009 | 1986 White Piazza 2.2L, Man, STi Turbo (SOLD)
2006 | 1986 Black Piazza Turbo Manual (SOLD)
2005 | 1986 White Piazza Turbo Auto (Pain in the ass)
2004 | 1986 White Piazza Manual Stock
2004 | 1986 Red Piazza Manual TO3, Haltech
2001 | 1986 Silver Piazza Manual Turbo

User avatar
GeminiCoupe
APC Member
APC Member
Posts: 692
Joined: Mon Jul 11, 2005 2:20 pm
Location: Victoria - The Boosted State

Post by GeminiCoupe » Mon Apr 30, 2007 12:58 pm

Tunney, if you need another cluster im pretty sure ive got one lieing around.
project - 76 Gemini Coupe G200z EFI Turbo
daily - 02 S15 Nissan 200SX GTspecS Turbo
wet-weather fun toy - TX 75 Gemini Sedan G200z

Post Reply