Contact About Us Links
FAQ - Search - Members - Groups - Register - Private Messages - Log in

Taco intermittent

 
Post new topic   Reply to topic    Welcome to IsuzuPiazza.com :: Uniting Isuzu/ Holden Piazza Enthusiasts since 2002 Forum Index -> Audio and Electronics
View previous topic :: View next topic  
Author Message
clyde
Probationary
Probationary


Joined: 11 Oct 2014
Posts: 21
Location: Brisbane, Australia

PostPosted: Mon Jul 04, 2016 6:31 pm    Post subject: Taco intermittent Reply with quote

Hi, My tacho has decided to work intermittently. Has anyone experienced this and what was the issue? I have standard dash instrumentation. Thanks, Clyde
Back to top
View user's profile Send private message
IZU069
Power Moderator
Power Moderator


Joined: 14 Sep 2005
Posts: 964
Location: Melbourne (Orstralia)

PostPosted: Wed Jul 06, 2016 12:31 pm    Post subject: Reply with quote

POST EDIT:
Ah Clyde - i should have noted the OP's name. Bad habits never change LOL!
I guess therefore my crap about the digidash was in vain... but i'll leave it below FWIW.

Normally i'd say get another tacho - eg from a similar vintage Rodeo or Jackaroo etc - but that assumes traditional separate round gauges and i think the Piazza analog dash was a single piece integrated type...
Hence as below, check connectors.
Then check the tacho's typically suspect components. [I've repaired several 1960s GT Bellett tachos & 1970s 117 tachos etc that were nothing more than dry caps and blown diodes; eg showing half range (or was it double?) is typically a blown signal diode.]

I return you to my usual diatribe...
/end POST EDIT.


Digidash i presume?

If analog i'd assume the usual dry capacitors or blown diodes, but digidash...

Of course it's assumed wiring etc is ok - i'd suggest the usual disconnect & reconnect of any connectors involved (behind the dash; distributor; igCoil, etc).
[ I can only reiterate how IMHO 95% of vehicle electrical problems - ESPECIALLY intermittents - are solved by simple disconnect & reconnect; not forgetting ROTATION of all same sized fuses - and relays - where possible. ]

Alas if it's a digidash issue i have no specific solution other than tracing.
Usually digidash problems are classic PSU failures - caps & diodes as above, but also inductor/coil or PCB track breakdowns. (The Power Supply Unit is an SMPS else transformer type - various voltages are produced including HV for the vac-fluoro displays. That they still worked after even 25 years imo is pretty darn amazing!)

Specific circuit failures are a different issue. For tachos however it is very likely that "filter" components (caps, resistors, diodes) may have failed - the filter removed the nasty spikes that typically exceed hundreds of volts from the igCoil primary before feeding to the (typically) 5V digidash circuitry.

I did once trace the voltmeter circuit because that was defunct in my digidash. As i recall, i concluded the problem was with a chip housed under the fuel/voltage display. Replacement would have been difficult.

It's likely the tacho is similar - probably a dedicated chip somewhere... The Piazza digidash predates major digitisation - ie it is not a single CPU that does everything (except i/o buffering etc) but is a collection of various digital chips.

I do have various datasheets somewhere, but a major problem for circuits like that is that those chips are no longer available. Of course sometimes you find some amazing NOS cache, but in the digidash's case you may then have to unsolder displays to get to the chips, then resolder, etc and that has risks...
Hence why i once proposed the Mk-2 & Mk-3 digidash upgrades - a complete smarts replacement using only the existing displays and display drivers - all smarts would be CPU driven; probably with downloadable upgrades and user modifiable functions; even cruise and wiper control, security, etc.


Most digidash owners have collected spares. They were often obtained for $100 or so. (That's far better than someone i know who once spent over $4,500 having their digidash repairs. That's more than i have ever spent buying a complete vehicle!)
_________________
IZU069 - ISUZU means a lot to me.
Back to top
View user's profile Send private message
eyecon
God member
God member


Joined: 12 Dec 2010
Posts: 769
Location: Australia's Capital

PostPosted: Thu Jul 07, 2016 1:07 pm    Post subject: Reply with quote

Hi Clyde
Is you car oz speck digidash or import analog?
Back to top
View user's profile Send private message Send e-mail
clyde
Probationary
Probationary


Joined: 11 Oct 2014
Posts: 21
Location: Brisbane, Australia

PostPosted: Sat Jul 09, 2016 4:33 pm    Post subject: Reply with quote

Hi, This is an imported Isuzu with an analog dash. Thanks.
Back to top
View user's profile Send private message
IZU069
Power Moderator
Power Moderator


Joined: 14 Sep 2005
Posts: 964
Location: Melbourne (Orstralia)

PostPosted: Mon Jul 11, 2016 7:13 am    Post subject: Reply with quote

Then it's a typical modern integrated tacho - not separate gauges etc.

First i'd suggest a wiring check as per above - ie disconnect & reconnect; especially the 2 round connectors to the instrument cluster...
Or trying another cluster, or maybe another tacho etc.

After that depends on how DYI you are - ie whether you can disassemble the cluster and check or replace components.
_________________
IZU069 - ISUZU means a lot to me.
Back to top
View user's profile Send private message
clyde
Probationary
Probationary


Joined: 11 Oct 2014
Posts: 21
Location: Brisbane, Australia

PostPosted: Tue Jul 12, 2016 7:38 pm    Post subject: Reply with quote

Hi, I have taken apart clusters before and every one was a pain in the *ss. I will have a closer look at the manual and see what I can do with it this weekend. I think (hope) it is a connection because it does work occasionally. I'll let you know how I go. Cheers.
Back to top
View user's profile Send private message
eyecon
God member
God member


Joined: 12 Dec 2010
Posts: 769
Location: Australia's Capital

PostPosted: Wed Jul 20, 2016 11:19 am    Post subject: Reply with quote

Failing that you can always buy another one.
http://page3.auctions.yahoo.co.jp/jp/auction/c466633326
Back to top
View user's profile Send private message Send e-mail
IZU069
Power Moderator
Power Moderator


Joined: 14 Sep 2005
Posts: 964
Location: Melbourne (Orstralia)

PostPosted: Thu Jul 21, 2016 11:01 am    Post subject: Reply with quote

Good find.
And only $500!

Let's hope it's a loose connection or cracked track or component.
_________________
IZU069 - ISUZU means a lot to me.
Back to top
View user's profile Send private message
eyecon
God member
God member


Joined: 12 Dec 2010
Posts: 769
Location: Australia's Capital

PostPosted: Thu Jul 21, 2016 11:09 am    Post subject: Reply with quote

Then add fees and postage. Probably closer to $600 by the time you receive it.
Back to top
View user's profile Send private message Send e-mail
IZU069
Power Moderator
Power Moderator


Joined: 14 Sep 2005
Posts: 964
Location: Melbourne (Orstralia)

PostPosted: Sat Jul 23, 2016 5:13 pm    Post subject: Reply with quote

I bought my Florians for less than that... mind you, these days they'd over a few $thousand each.

And yesterday i was offered $100 EACH for GT Bellett tail light lenses - 3 lenses per side, that's $600! What a shame i gave the last away and the rest were exported... (ha ha).

Ooops- don'tcha hate how those with sparts and DIY capabilities seem to relish the status quo?
_________________
IZU069 - ISUZU means a lot to me.
Back to top
View user's profile Send private message
clyde
Probationary
Probationary


Joined: 11 Oct 2014
Posts: 21
Location: Brisbane, Australia

PostPosted: Sun Jul 24, 2016 5:15 pm    Post subject: Reply with quote

Hi guys, success today with the tacho. It must be a bad connector but not sure which one. I went over the wiring under the bonnet and traced back to the firewall. When I started her up the tacho was working. Hope whatever I did stays in that state. I know the tacho works at least. Thanks for the info.
Back to top
View user's profile Send private message
IZU069
Power Moderator
Power Moderator


Joined: 14 Sep 2005
Posts: 964
Location: Melbourne (Orstralia)

PostPosted: Mon Jul 25, 2016 12:51 pm    Post subject: Reply with quote

Who's the wiseguy that said 95% of electrical faults were...
Damned JIGJAMers!

Good to hear that it's probably an external fault rather than something in the dash.
The problem wire is probably black-red (black with red trace) - that's the standard "points" wire color used by Isuzu - ie from distributor points or ignitor to igCoil -ve and tacho input. (But don't confuse with RB Gemini reluctor etc or earlier Bellett/Florian color codes.)

Tracing from the igCoil is probably the easiest, but good electrical diagrams (which you Piazza Manual should have) may be invaluable under the dash to find which connectors are relevant.

But if your disconnect-reconnect has solved the problem, it's likely to be solved for quite a while.
If not, maybe some Inox or WD40 or contact cleaner sprayed into disconnected connectors might fix it permanently.

Trivially, shorts to GND can be an issue - ie dirt etc that shorts the tacho's coil- signal to GND as opposed to insulating the through signal. Such shorts are often used for anti-theft or anti-start - and sometimes engine-kills - but if far enough away from the igCoil or weak it may be enough to kill the tacho but not the ignition.


Guess i get to hand on to my analog Piazza dash for a few more years...
_________________
IZU069 - ISUZU means a lot to me.
Back to top
View user's profile Send private message
eyecon
God member
God member


Joined: 12 Dec 2010
Posts: 769
Location: Australia's Capital

PostPosted: Mon Jul 25, 2016 10:43 pm    Post subject: Reply with quote

Good work Clyde
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Welcome to IsuzuPiazza.com :: Uniting Isuzu/ Holden Piazza Enthusiasts since 2002 Forum Index -> Audio and Electronics All times are GMT + 10 Hours
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum